We have successfully resolved the issue affecting Subscriber API performance. The root cause was identified, and corrective measures have been implemented. Following validation, services are operating normally, and we continue to monitor the platform to ensure ongoing stability. As the issue has been resolved, this incident will now be closed.
Posted Jul 02, 2026 - 17:30 PDT
Identified
Following a detailed investigation, we have determined that the impact of the reported issue is more limited in scope than initially assessed. As a result, the issue has been reclassified as a non-outage (Severity 0/1) event. Please note that resolution efforts are still actively underway.
Posted Jul 02, 2026 - 16:09 PDT
Investigating
We have seen indication of a potential intermittent issue with Subscriber API timeout in the Zeta Marketing Platform. We are actively working to identify the issue (impact and cause) and will update you with findings and confirmation of affected services once collected. Additional communications will be sent periodically with updates while we move through identification, impact analysis, and recovery. We value your trust and apologize for any inconvenience.