Intermittent Access Issues with ZMP Web UI

Incident Report for Zeta Marketing Platform

Resolved

The earlier issue affecting login access to the ZMP web interface has been resolved. All services are now fully operational, and there is no ongoing impact.
Our team will continue to monitor the platform to ensure stability. Thank you for your patience.
Posted Jul 28, 2025 - 17:25 PDT

Investigating

We have seen indication of a potential high severity issue with the Zeta Marketing Platform. Users are experiencing significant delays when attempting to load and interact with the Zeta Marketing Platform interface. Pages are taking longer than normal to respond.
Our team is actively investigating and working to restore stable access as soon as possible
Posted Jul 28, 2025 - 16:35 PDT
This incident affected: Web Application.