The root cause has been identified, recovery is complete and campaign latency has returned to normal levels. We’ll continue to monitor performance closely to ensure ongoing stability. Thank you for your patience during this incident.
Posted May 26, 2025 - 09:32 PDT
Update
Recovery efforts are underway as we continue to investigate the incident. Latency in campaign sends is steadily decreasing, and we expect processing times to return to normal soon. We’ll provide an update within the hour or sooner if more information becomes available.
Posted May 26, 2025 - 08:28 PDT
Investigating
Users are experiencing significant latency in campaign delivery. Campaign sends are taking longer than expected to process and deliver to recipients. Technical teams are actively investigating the delivery delays and working to restore normal processing times. The next update will be provided as soon as possible.