Zeta Marketing Platform is experiencing a campaign processing disruption.

Incident Report for Zeta Marketing Platform

Resolved

The issue has been resolved, and new campaigns are running as expected. We are continuing to reprocess any previously affected campaigns.
Posted Feb 27, 2025 - 14:15 PST

Identified

Our team has identified the issue and is working on reprocessing any affected campaigns
Posted Feb 27, 2025 - 13:45 PST

Update

We are continuing to investigate this issue.
Posted Feb 27, 2025 - 13:22 PST

Investigating

We are currently looking into an issue that may be impacting campaign delivery. Our team is actively investigating, and we will provide updates as soon as possible.
Posted Feb 27, 2025 - 13:18 PST
This incident affected: Platform (Campaigns).