Zeta Marketing Platform is experiencing a service disruption on our reporting services

Incident Report for Zeta Marketing Platform US

Resolved

The issue is now resolved and Reporting Services are fully operational. We have increased the infrastructure capacity to handle more workloads.
Posted Sep 10, 2025 - 17:10 PDT

Identified

Our team has implemented several fixes that have already resolved the errors, and Reporting Services are now operational.
We're closely monitoring the system to ensure stability and will keep you updated as we gather more information and make progress to ensure full resolution.
Posted Sep 10, 2025 - 15:51 PDT

Investigating

Zeta Marketing Platform is experiencing a service disruption on our reporting services. We are actively working to identify the issue (impact and cause). Additional communications will be sent periodically with updates while we move through identification, impact analysis, and recovery. We value your trust and apologize for any inconvenience.
Posted Sep 10, 2025 - 14:43 PDT
This incident affected: Platform (Reports).