Resolved - No Impact to Services The issue we were investigating has been fully resolved. We have confirmed that there was no impact to any customer-facing services. The issue was isolated to internal systems and has since been addressed.
Posted Jun 30, 2025 - 05:53 PDT
Identified
Update - Issue Impact Limited to Internal Users
At this time, we have determined that the impact appears to be limited to internal users only. External customer-facing services remain unaffected.
Our teams are actively analyzing the root cause and will provide further updates as we progress through identification, impact validation, and recovery. We appreciate your patience and understanding as we work to ensure full resolution.
Posted Jun 30, 2025 - 05:46 PDT
Investigating
We have seen indication of a potential high severity issue with the Zeta Marketing Platform. We are actively working to identify the issue (impact and cause) and will update you with findings and confirmation of affected services once collected. Additional communications will be sent periodically with updates while we move through identification, impact analysis, and recovery. We value your trust and apologize for any inconvenience.