Web interface is inaccessible due to a platform disruption

Incident Report for Zeta Marketing Platform

Resolved

This incident has been resolved.
Posted Mar 05, 2025 - 03:52 PST

Monitoring

The issue has been resolved. We are continuing to monitor the situation closely.
Posted Mar 05, 2025 - 03:48 PST

Identified

The Zeta Marketing Platform is currently experiencing a complete disruption preventing all users from accessing the web interface. Our team is actively investigating and working to restore functionality as soon as possible. The next update will provide updates as soon as possible.
Posted Mar 05, 2025 - 03:25 PST
This incident affected: Web Application.