Zeta Marketing Platform is experiencing a service disruption in Visual Editor

Incident Report for Zeta Marketing Platform US

Resolved

This incident has been fully resolved, and users should now be able to save changes in the Visual Editor. We will continue monitoring closely to ensure ongoing stability.
Posted Sep 22, 2025 - 18:04 PDT

Identified

We've identified the root cause of the Visual Editor issue preventing some users from saving changes. Our team has deployed a fix and will continue to share updates as we move toward resolution.
Posted Sep 22, 2025 - 17:29 PDT

Investigating

Zeta Marketing Platform is experiencing a service disruption in our Visual Editor for a subset of users. We are actively working to identify the issue (impact and cause). Additional communications will be sent periodically with updates while we move through identification, impact analysis, and recovery. We value your trust and apologize for any inconvenience.
Posted Sep 22, 2025 - 15:18 PDT
This incident affected: Platform (Campaigns).